build_verify 1.1.1
build_verify: ^1.1.1 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Test utility to ensure generated Dart code within a package is up-to-date when using package:build.

2
likes
90 / 110
pub points
75 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 3 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_verify/build_verify.dart that imports:
  • package:build_verify/src/impl.dart that imports:
  • package:build_verify/src/utils.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
path^1.0.01.7.01.8.0
test^1.0.01.15.71.16.4
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
analyzer-0.41.21.1.0
args-1.6.02.0.0
async-2.4.22.5.0
boolean_selector-2.0.02.1.0
charcode-1.1.31.2.0
cli_util-0.2.00.3.0
collection-1.14.131.15.0
convert-2.1.13.0.0
coverage-0.14.21.0.0
crypto-2.1.53.0.0
file-5.2.16.1.0
glob-1.2.02.0.0
http-0.12.20.13.0
http_multi_server-2.2.03.0.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
io-0.3.51.0.0
js-0.6.20.6.3
logging-0.11.41.0.0
matcher-0.12.90.12.10
meta-1.2.41.3.0
mime-0.9.71.0.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
node_preamble-1.4.131.4.13
package_config-1.9.32.0.0
pool-1.4.01.5.0
pub_semver-1.4.42.0.0
shelf-0.7.91.0.0
shelf_packages_handler-2.0.13.0.0
shelf_static-0.2.9+21.0.0
shelf_web_socket-0.2.4+11.0.0
source_map_stack_trace-2.0.02.1.0
source_maps-0.10.90.10.10
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
stream_channel-2.0.02.1.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
test_api-0.2.18+10.2.19
test_core-0.3.11+40.3.14
typed_data-1.2.01.3.0
vm_service-4.2.06.1.0+1
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.0.0
webkit_inspection_protocol-0.7.51.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

2
likes
90
pub points
75%
popularity

Publisher

j832.com

Test utility to ensure generated Dart code within a package is up-to-date when using package:build.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

path, test

More

Packages that depend on build_verify