pub_updater 0.2.2 icon indicating copy to clipboard operation
pub_updater: ^0.2.2 copied to clipboard

A Dart package which enables checking whether a package is up to date.

20
likes
130/ 130
pub points
89%
popularity

We analyzed this package 26 hours ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 10 API elements (70.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:pub_updater/pub_updater.dart that imports:
  • package:pub_updater/src/pub_updater.dart that imports:
  • package:process/process.dart that imports:
  • package:process/src/interface/process_wrapper.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.13.30.13.50.13.5
json_annotation^4.1.04.6.04.6.0
process^4.2.34.2.44.2.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
collection-1.16.01.16.0
file-6.1.26.1.2
http_parser-4.0.14.0.1
meta-1.8.01.8.0
path-1.8.21.8.2
platform-3.1.03.1.0
source_span-1.9.11.9.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.14, Dart 2.17.5.

20
likes
130
pub points
89%
popularity

Publisher

verified publisher iconverygood.ventures

A Dart package which enables checking whether a package is up to date.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

http, json_annotation, process

More

Packages that depend on pub_updater