pub_updater 0.2.2 icon indicating copy to clipboard operation
pub_updater: ^0.2.2 copied to clipboard

A Dart package which enables checking whether a package is up to date.

Pub Updater #

Very Good Ventures

Developed with πŸ’™ by Very Good Ventures πŸ¦„

Pub build coverage style: very good analysis License: MIT


A Dart package which enables checking whether packages are up to date and supports updating them.

Intended for use in CLIs for prompting users to auto-update.

Usage #

import 'package:pub_updater/pub_updater.dart';

void main() async {
  // Create an instance of PubUpdater
  final pubUpdater = PubUpdater();

  // Check whether or not version 0.1.0 is the latest version of my_package
  final isUpToDate = await pubUpdater.isUpToDate(
    packageName: 'my_package',
    currentVersion: '0.1.0',
  );

  // Trigger an upgrade to the latest version if my_package is not up to date
  if (!isUpToDate) {
    await pubUpdater.update(packageName: 'my_package');
  }

  // You can also query the latest version available for a specific package.
  final latestVersion = await pubUpdater.getLatestVersion('my_package');
}
20
likes
130
pub points
89%
popularity

Publisher

verified publisher iconverygood.ventures

A Dart package which enables checking whether a package is up to date.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

http, json_annotation, process

More

Packages that depend on pub_updater