platform 2.2.1

Platform #

Build Status - Coverage Status - Pub

A generic platform abstraction for Dart.

Like dart:io, package:platform supplies a rich, Dart-idiomatic API for accessing platform-specific information.

package:platform provides a lightweight wrapper around the static Platform properties that exist in dart:io. However, it uses instance properties rather than static properties, making it possible to mock out in tests.

2.2.1 #

  • Add operatingSystemVersion

2.2.0 #

  • Declare compatibility with Dart 2 stable
  • Update dependency on package:test to 1.0

2.1.2 #

  • Relax sdk upper bound constraint to '<2.0.0' to allow 'edge' dart sdk use.

2.1.1 #

  • Bumped maximum Dart SDK version to 2.0.0-dev.infinity

2.1.0 #

  • Added localeName
  • Bumped minimum Dart SDK version to 1.24.0-dev.0.0

2.0.0 #

  • Added stdinSupportsAnsi and stdinSupportsAnsi
  • Removed ansiSupported

1.1.1 #

  • Updated LocalPlatform to use new dart.io API for ansi color support queries
  • Bumped minimum Dart SDK version to 1.23.0-dev.10.0

1.1.0 #

  • Added ansiSupported
  • Bumped minimum Dart SDK version to 1.23.0-dev.9.0

1.0.2 #

  • Minor doc updates

1.0.1 #

  • Added const constructors for Platform and LocalPlatform

1.0.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  platform: ^2.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:platform/platform.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
97
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72
Overall:
Weighted score of the above. [more]
93
Learn more about scoring.

We analyzed this package on Sep 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:platform/platform.dart with components: io.

Health suggestions

Fix lib/src/interface/local_platform.dart. (-0.50 points)

Analysis of lib/src/interface/local_platform.dart reported 1 hint:

line 45 col 41: 'packageRoot' is deprecated and shouldn't be used.

Maintenance issues and suggestions

Use analysis_options.yaml. (-10 points)

Change the name of your package's .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and platform.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0-dev.0.0 <3.0.0
Dev dependencies
test ^1.0.0