platform 3.1.0 icon indicating copy to clipboard operation
platform: ^3.1.0 copied to clipboard

A pluggable, mockable platform abstraction for Dart.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add platform

With Flutter:

 $ flutter pub add platform

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  platform: ^3.1.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:platform/platform.dart';
27
likes
110
pub points
100%
popularity

A pluggable, mockable platform abstraction for Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

More

Packages that depend on platform