large Flutter Favorite logosmall Flutter Favorite logo

firebase_core 1.3.0 icon indicating copy to clipboard operation
firebase_core: ^1.3.0 copied to clipboard

Flutter plugin for Firebase Core, enabling connecting to multiple Firebase apps.

2484
likes
90/ 140
pub points
100%
popularity

We analyzed this package 9 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://firebase.flutter.dev/docs/core/usage was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: firebase_core,
    • contains a version property, and,
    • does not contain a publish_to property.

packages/firebase_core/firebase_core/pubspec.yaml from the repository URL missmatch: expected https://github.com/FirebaseExtended/flutterfire but got https://github.com/firebase/flutterfire.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 16 API elements (81.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:firebase_core/firebase_core.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: The method 'verifyExtends' isn't defined for the type 'FirebaseAppPlatform'.

lib/src/firebase_app.dart:17:25

   ╷
17 │     FirebaseAppPlatform.verifyExtends(_delegate);
   │                         ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/firebase_app.dart

INFO: The import of 'package:meta/meta.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/widgets.dart'.

lib/firebase_core.dart:10:8

   ╷
10 │ import 'package:meta/meta.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/firebase_core.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core_platform_interface^4.0.14.5.24.5.2
firebase_core_web^1.1.01.7.32.1.0
flutterflutter0.0.00.0.0
meta^1.3.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
boolean_selector-2.1.12.1.1
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.17.01.17.0
fake_async-1.3.11.3.1
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
js-0.6.50.6.6
matcher-0.12.130.12.14
material_color_utilities-0.2.00.2.0
path-1.8.21.8.3
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
test_api-0.4.160.4.18
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.0` on firebase_core_web does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions firebase_core_web to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

2484
likes
90
pub points
100%
popularity

Publisher

verified publisher iconfirebase.google.com

Flutter plugin for Firebase Core, enabling connecting to multiple Firebase apps.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

firebase_core_platform_interface, firebase_core_web, flutter, meta

More

Packages that depend on firebase_core