firebase_core_web 0.1.1+2

  • Readme
  • Changelog
  • Installing
  • 94

firebase_core_web #

The web implementation of firebase_core.

Usage #

Import the package #

This package is the endorsed implementation of firebase_core for the web platform since version 0.4.3, so it gets automatically added to your dependencies by depending on firebase_core: ^0.4.3.

No modifications to your pubspec.yaml should be required in a recent enough version of Flutter (>=1.12.13+hotfix.4):

...
dependencies:
  ...
  firebase_core: ^0.4.3
  ...

Updating index.html #

Due to this bug in dartdevc, you will need to manually add the Firebase JavaScript file to your index.html file.

In your app directory, edit web/index.html to add the line:

<html>
    ...
    <body>
        <script src="https://www.gstatic.com/firebasejs/7.5.0/firebase-app.js"></script>
        <!-- Other firebase SDKs/config here -->
        <script src="main.dart.js"></script>
    </body>
</html>

Initialize Firebase #

If your app is using the "default" Firebase app, you need to initialize it now, following the steps in the Firebase Web Setup docs.

Specifically, you'll want to add the following lines to your web/index.html file:

<body>
  <!-- Previously loaded Firebase SDKs -->

  <!-- ADD THIS BEFORE YOUR main.dart.js SCRIPT -->
  <script>
    // TODO: Replace the following with your app's Firebase project configuration.
    // See: https://support.google.com/firebase/answer/7015592
    var firebaseConfig = {
      apiKey: "...",
      authDomain: "[YOUR_PROJECT].firebaseapp.com",
      databaseURL: "https://[YOUR_PROJECT].firebaseio.com",
      projectId: "[YOUR_PROJECT]",
      storageBucket: "[YOUR_PROJECT].appspot.com",
      messagingSenderId: "...",
      appId: "1:...:web:...",
      measurementId: "G-..."
    };
    // Initialize Firebase
    firebase.initializeApp(firebaseConfig);
  </script>
  <!-- END OF FIREBASE INIT CODE -->

  <script src="main.dart.js"></script>
</body> 

Using the plugin #

Once you have modified your web/index.html file you should be able to use package:firebase_core as normal.

0.1.1+2 #

  • Update setup instructions in the README.

0.1.1+1 #

0.1.1 #

  • Require Flutter SDK 1.12.13+hotfix.4 or greater.
  • Fix homepage.

0.1.0+3 #

  • Remove the deprecated author: field from pubspec.yaml
  • Bump the minimum Flutter version to 1.10.0.

0.1.0+2 #

  • Add documentation for initializing the default app.

0.1.0+1 #

  • Use package:firebase for firebase functionality.

0.1.0 #

  • Initial open-source release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_core_web: ^0.1.1+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_core_web/firebase_core_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
99
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
94
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and firebase_core_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
firebase ^7.0.0 7.2.1
firebase_core_platform_interface ^1.0.0 1.0.4
flutter 0.0.0
flutter_web_plugins 0.0.0
js ^0.6.1 0.6.1+1
meta ^1.1.7 1.1.8
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
http 0.12.0+4
http_parser 3.1.4
matcher 0.12.6
path 1.6.4
pedantic 1.9.0
plugin_platform_interface 1.0.2
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
firebase_core ^0.4.2+1
flutter_test