tim_fluttify 0.0.1
tim_fluttify: ^0.0.1 copied to clipboard

An `Tencent IM` Component, Powered By `Fluttify` Compiler, A Dart Bindings Generator For Native SDK.

0
likes
65/ 130
pub points
0%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 46 API elements (19.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:tim_fluttify/tim_fluttify.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 700 issues. Showing the first 2:

lib/src/android/com/tencent/av/Message/AvMsg.g.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/android/com/tencent/av/Message/AvMsg/Type.g.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
foundation_fluttify^0.7.30.7.30.11.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.3.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.3` on foundation_fluttify does not support the stable version `0.8.0`.

Try running dart pub upgrade --major-versions foundation_fluttify to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Flutter 2.2.3, Dart 2.13.4.

0
likes
65
pub points
0%
popularity

Publisher

fluttify.com

An `Tencent IM` Component, Powered By `Fluttify` Compiler, A Dart Bindings Generator For Native SDK.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, foundation_fluttify

More

Packages that depend on tim_fluttify