stomp_dart_client 0.3.5

Dart native js
Flutter Android iOS web

Dart STOMP client for easy messaging interoperability. Build with flutter in mind, but should work for every dart application.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  stomp_dart_client: ^0.3.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:stomp_dart_client/stomp.dart';
import 'package:stomp_dart_client/stomp_config.dart';
import 'package:stomp_dart_client/stomp_frame.dart';
import 'package:stomp_dart_client/stomp_handler.dart';
import 'package:stomp_dart_client/stomp_parser.dart';
12
likes
110
pub points
85%
popularity

Publisher

blackhorse-one.com

Dart STOMP client for easy messaging interoperability. Build with flutter in mind, but should work for every dart application.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

meta, web_socket_channel

More

Packages that depend on stomp_dart_client