redux_remote_devtools 2.0.0
redux_remote_devtools: ^2.0.0 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

Remote DevTools for Redux.dart. This package connects a Dart Redux store to the Remote Devtools Server, allowing the developer to inspect changes to the Redux Store during runtime.

8
likes
105 / 110
pub points
82 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 105 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:4:25

  ╷
4 │ This is inline with the <a href="http://dart-lang.github.io/linter/lints/one_member_abstracts.html">Dart styleguide</a>, which advocates using function typedefs instead of single method abstract classes.</p>
  │                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 42 API elements (47.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
redux>=3.0.0 <5.0.04.0.0+35.0.0
redux_dev_tools>=0.4.0 <1.0.00.5.20.5.2
socketcluster_client^0.2.00.2.00.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=3.0.0 <5.0.0` on redux does not support the stable version `5.0.0`, that was published 5 days ago.

When redux is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions redux to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

8
likes
105
pub points
82%
popularity

Remote DevTools for Redux.dart. This package connects a Dart Redux store to the Remote Devtools Server, allowing the developer to inspect changes to the Redux Store during runtime.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

michael@20papercups.net

License

MIT (LICENSE)

Dependencies

redux, redux_dev_tools, socketcluster_client

More

Packages that depend on redux_remote_devtools