maps 0.5.0 icon indicating copy to clipboard operation
maps: ^0.5.0 copied to clipboard

PlatformiOSweb

A cross-platform geographic maps package. Supports Apple MapKit, Bing Maps, and Google Maps. Works in all platforms supported by Flutter, including browsers.

32
likes
100/ 140
pub points
64%
popularity

We analyzed this package 22 hours ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 99 out of 138 API elements (71.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:maps/maps.dart that imports:
  • package:maps/src/adapters/google_maps.dart that imports:
  • package:maps/src/adapters/google_maps_impl_default.dart that imports:
  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `Windows`.

Because:

  • package:maps/maps.dart that imports:
  • package:maps/src/adapters/google_maps.dart that imports:
  • package:maps/src/adapters/google_maps_impl_default.dart that imports:
  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/platform_interface.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:maps/maps.dart that imports:
  • package:maps/src/adapters/google_maps.dart that imports:
  • package:maps/src/adapters/google_maps_impl_default.dart that imports:
  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/platform_interface.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:maps/maps.dart that imports:
  • package:maps/src/adapters/google_maps.dart that imports:
  • package:maps/src/adapters/google_maps_impl_default.dart that imports:
  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/platform_interface.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `iOS`.

Because:

  • package:maps/maps.dart that imports:
  • package:maps/src/adapters/google_maps.dart that imports:
  • package:maps/src/adapters/google_maps_impl_default.dart that imports:
  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_android_cookie_manager.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: The import of 'package:meta/meta.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/widgets.dart'.

lib/src/adapters/bing_maps.dart:17:8

   ╷
17 │ import 'package:meta/meta.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/adapters/bing_maps.dart

INFO: Don't use web-only libraries outside Flutter web plugin packages.

lib/src/adapters/bing_maps_impl_browser.dart:15:1

   ╷
15 │ import 'dart:html' as html;
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/adapters/bing_maps_impl_browser.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
apple_maps_flutter0.1.30.1.31.2.0
collection^1.15.01.17.01.17.1
cryptography^2.0.02.0.52.0.5
flutterflutter0.0.00.0.0
js^0.6.30.6.50.6.7
kind^0.5.00.5.20.5.2
meta^1.3.01.8.01.9.0
url_launcher^6.0.26.1.86.1.8
web_browser^0.5.00.5.00.5.0
web_node^0.2.00.2.10.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
charcode-1.3.11.3.1
crypto-3.0.23.0.2
csp-0.1.10.1.1
csslib-0.17.20.17.2
cupertino_icons-1.0.51.0.5
fixnum-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
html-0.15.10.15.1
material_color_utilities-0.2.00.2.0
mime-1.0.41.0.4
path-1.8.31.8.3
plugin_platform_interface-2.1.32.1.3
protobuf-2.1.02.1.0
share-2.0.42.0.4
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
universal_html-2.0.82.0.8
universal_io-2.0.42.0.4
url_launcher_android-6.0.236.0.23
url_launcher_ios-6.0.186.0.18
url_launcher_linux-3.0.23.0.2
url_launcher_macos-3.0.23.0.2
url_launcher_platform_interface-2.1.12.1.1
url_launcher_web-2.0.142.0.14
url_launcher_windows-3.0.33.0.3
vector_math-2.1.42.1.4
webview_flutter-2.8.04.0.2
webview_flutter_android-2.10.43.2.4
webview_flutter_platform_interface-1.9.52.0.1
webview_flutter_wkwebview-2.9.53.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `0.1.3` on apple_maps_flutter does not support the stable version `0.1.4`.

Try running dart pub upgrade --major-versions apple_maps_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.9.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

32
likes
100
pub points
64%
popularity

Publisher

verified publisher icondint.dev

A cross-platform geographic maps package. Supports Apple MapKit, Bing Maps, and Google Maps. Works in all platforms supported by Flutter, including browsers.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

apple_maps_flutter, collection, cryptography, flutter, js, kind, meta, url_launcher, web_browser, web_node

More

Packages that depend on maps