laksadart 0.1.19

Dart native
Flutter Android iOS

Dart library for Zilliqa's Blockchain, including Schnorr, wallet/account/keys manager, RPCMethod, Transactions and Contracts deploy/call.

0
likes
70 / 110
pub points
33 %
popularity

We analyzed this package on Sep 30, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 70 out of 889 API elements (7.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:laksadart/laksadart.dart that imports:
  • package:laksadart/src/messenger/index.dart that imports:
  • package:laksadart/src/messenger/Blockchain.dart that imports:
  • package:laksadart/src/transaction/transaction.dart that imports:
  • package:laksadart/src/crypto/index.dart that imports:
  • package:laksadart/src/crypto/isolates.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 239 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/Laksa.dart:9:21

   ╷
9  │   var DefaultConfig = new ZilliqaConfig({
   │ ┌─────────────────────^
10 │ │   'Default': new ConfigItem(
11 │ │       CHAIN_ID: 3,
12 │ │       Network_ID: 'TestNet',
13 │ │       nodeProviderUrl: 'http://localhost:4200'),
14 │ │   'Staging': new ConfigItem(
15 │ │       CHAIN_ID: 63,
16 │ │       Network_ID: 'TestNet',
17 │ │       nodeProviderUrl: 'https://staging-api.aws.z7a.xyz'),
18 │ │   'DevNet': new ConfigItem(
19 │ │       CHAIN_ID: 333,
20 │ │       Network_ID: 'DevNet',
21 │ │       nodeProviderUrl: 'https://dev-api.zilliqa.com'),
22 │ │   'TestNet': new ConfigItem(
23 │ │       CHAIN_ID: 2,
24 │ │       Network_ID: 'TestNet',
25 │ │       nodeProviderUrl: 'https://api.zilliqa.com'),
26 │ │   'MainNet': new ConfigItem(
27 │ │       CHAIN_ID: 1,
28 │ │       Network_ID: 'MainNet',
29 │ │       nodeProviderUrl: 'https://api.zilliqa.com')
30 │ │ });
   │ └──^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/Laksa.dart

INFO: Unnecessary new keyword.

lib/src/Laksa.dart:10:14

   ╷
10 │     'Default': new ConfigItem(
   │ ┌──────────────^
11 │ │       CHAIN_ID: 3,
12 │ │       Network_ID: 'TestNet',
13 │ │       nodeProviderUrl: 'http://localhost:4200'),
   │ └───────────────────────────────────────────────^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/Laksa.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bip32^1.0.51.0.51.0.5
bip39^1.0.31.0.31.0.3
collection^1.14.111.14.131.14.13
convert^2.1.12.1.12.1.1
crypto^2.0.62.1.52.1.5
fixnum^0.10.90.10.110.10.11
http^0.12.00.12.20.12.2
json_serializable^2.0.12.3.03.5.0
meta^1.1.61.2.31.2.3
pointycastle^1.0.0-rc41.0.21.0.2
protobuf^0.10.50.10.81.0.1
tuple^1.0.21.0.31.0.3
uuid^1.0.31.0.32.2.2
validators^1.0.0+11.0.0+12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.36.40.40.4
args-1.6.01.6.0
async-2.4.22.4.2
boolean_selector-2.0.02.0.0
bs58check-1.0.11.0.1
build-1.5.01.5.0
build_config-0.4.20.4.2
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
coverage-0.14.10.14.1
csslib-0.16.20.16.2
dart_style-1.2.91.3.7
front_end-0.1.190.1.29
glob-1.2.01.2.0
hex-0.1.20.1.2
html-0.14.0+30.14.0+3
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
io-0.3.40.3.4
js-0.6.20.6.2
json_annotation-2.3.03.1.0
kernel-0.3.190.3.29
logging-0.11.40.11.4
matcher-0.12.60.12.9
mime-0.9.70.9.7
multi_server_socket-1.0.21.0.2
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
node_preamble-1.4.121.4.12
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.32.1.3
shelf-0.7.90.7.9
shelf_packages_handler-2.0.02.0.0
shelf_static-0.2.80.2.8
shelf_web_socket-0.2.30.2.3
source_gen-0.9.4+40.9.7+1
source_map_stack_trace-2.0.02.0.0
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
test_api-0.2.160.2.18
test_core-0.3.70.3.11+1
typed_data-1.2.01.2.0
vm_service-4.2.05.2.0
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
webkit_inspection_protocol-0.7.30.7.3
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.0.1` on json_serializable does not support the latest published version `3.5.0`

pubspec.yaml:23:22

   ╷
23 │   json_serializable: ^2.0.1
   │                      ^^^^^^
   ╵
The constraint `^0.10.5` on protobuf does not support the latest published version `1.0.1`

pubspec.yaml:19:13

   ╷
19 │   protobuf: ^0.10.5
   │             ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
33%
popularity

Dart library for Zilliqa's Blockchain, including Schnorr, wallet/account/keys manager, RPCMethod, Transactions and Contracts deploy/call.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ghostcorn@gmail.com

License

MIT (LICENSE)

Dependencies

bip32, bip39, collection, convert, crypto, fixnum, http, json_serializable, meta, pointycastle, protobuf, tuple, uuid, validators

More

Packages that depend on laksadart