input_sheet 0.2.1
input_sheet: ^0.2.1 copied to clipboard

Flutter Android iOS

A flutter package to help apps with extensive forms, implementing inputs as BottomSheet to make it enjoyable.

23
likes
70 / 110
pub points
52 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 242 API elements (8.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:input_sheet/input_sheet.dart that imports:
  • package:input_sheet/sheet.dart that imports:
  • package:keyboard_utils/widgets.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: 'overflow' is deprecated and shouldn't be used. Use clipBehavior instead. See the migration guide in flutter.dev/go/clip-behavior. This feature was deprecated after v1.22.0-12.0.pre..

lib/components/IpsPhoto.dart:23:7

   ╷
23 │       overflow: Overflow.visible,
   │       ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/components/IpsPhoto.dart

INFO: 'Overflow' is deprecated and shouldn't be used. Use clipBehavior instead. See the migration guide in flutter.dev/go/clip-behavior. This feature was deprecated after v1.22.0-12.0.pre..

lib/components/IpsPhoto.dart:23:17

   ╷
23 │       overflow: Overflow.visible,
   │                 ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/components/IpsPhoto.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
after_layout^1.0.7+21.0.7+21.0.7+2
cached_network_image^2.2.0+12.5.02.5.0
camera^0.5.8+10.5.8+170.6.4+5
flutter_cupertino_date_picker^1.0.241.0.26+21.0.26+2
flutter_feather_icons^1.0.31.0.31.0.3
flutter_keyboard_size^0.1.2+20.1.2+20.1.2+2
flutter_masked_text^0.8.00.8.00.8.0
flutter_mobx^1.1.01.1.0+21.1.0+2
intl^0.16.10.16.10.16.1
keyboard_utils^1.2.11.2.41.2.4
mobx^1.2.11.2.1+41.2.1+4
path_provider^1.6.81.6.271.6.27
permission_handler^5.0.1+15.0.1+15.0.1+1
quiver^2.0.52.1.52.1.5
uuid^2.0.42.2.22.2.2
video_compress^2.0.02.1.12.1.1
video_player^0.10.110.10.12+51.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.132.0.13
args-1.6.01.6.0
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
clock-1.0.11.1.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_blurhash-0.5.00.5.0
flutter_cache_manager-2.1.12.1.1
http-0.12.20.12.2
http_parser-3.1.43.1.4
image-2.1.192.1.19
js-0.6.3-nullsafety.30.6.3-nullsafety.3
matcher-0.12.90.12.10-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
nested-0.0.40.0.4
octo_image-0.3.00.3.0
path-1.7.01.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+80.0.4+8
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
permission_handler_platform_interface-2.0.12.0.1
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
provider-4.3.2+44.3.2+4
rxdart-0.25.00.25.0
source_span-1.7.01.8.0-nullsafety.4
sqflite-1.3.2+21.3.2+2
sqflite_common-1.0.31.0.3
stack_trace-1.9.61.10.0-nullsafety.6
string_scanner-1.0.51.1.0-nullsafety.3
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
video_player_platform_interface-2.2.02.2.0
video_player_web-0.1.4+10.1.4+1
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2
xml-4.5.14.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.8+1` on camera does not support the latest published version `0.6.4+5`

pubspec.yaml:17:11

   ╷
17 │   camera: ^0.5.8+1
   │           ^^^^^^^^
   ╵
The constraint `^0.10.11` on video_player does not support the latest published version `1.0.1`

pubspec.yaml:23:17

   ╷
23 │   video_player: ^0.10.11
   │                 ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs