get_server 1.1.1 icon indicating copy to clipboard operation
get_server: ^1.1.1 copied to clipboard

A backend server (http and websocket) that makes it possible to program with Flutter syntax and reuse existing code

226
likes
120/ 130
pub points
76%
popularity

We analyzed this package 26 hours ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 436 out of 1265 API elements (34.5 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:get_server/get_server.dart that imports:
  • package:get_server/src/widgets/pageable.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/framework/get_connect/http/src/response/response.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
jaguar_jwt^3.0.03.0.03.0.0
meta>=1.3.0 <2.0.01.7.01.7.0
mime^1.0.01.0.11.0.1
path^1.8.01.8.11.8.1
Transitive dependencies
PackageConstraintCompatibleLatest
auth_header-3.0.13.0.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.5, Dart 2.15.1.

226
likes
120
pub points
76%
popularity

Publisher

shield icon for verified publishersgetx.site

A backend server (http and websocket) that makes it possible to program with Flutter syntax and reuse existing code

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

jaguar_jwt, meta, mime, path

More

Packages that depend on get_server