get_cli 1.8.1 icon indicating copy to clipboard operation
get_cli: ^1.8.1 copied to clipboard

Official CLI for GetX™ framework to build Flutter and Server Applications easily

396
likes
90/ 130
pub points
93%
popularity

We analyzed this package 47 hours ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 131 out of 833 API elements (15.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:get_cli/get_cli.dart that imports:
  • package:get_cli/core/generator.dart that imports:
  • package:get_cli/commands/impl/help/help.dart that imports:
  • package:get_cli/commands/commands_list.dart that imports:
  • package:get_cli/commands/impl/commads_export.dart that imports:
  • package:get_cli/commands/impl/sort/sort.dart that imports:
  • package:get_cli/functions/create/create_single_file.dart that imports:
  • package:get_cli/functions/sorter_imports/sort.dart that imports:
  • package:get_cli/common/utils/pubspec/pubspec_utils.dart that imports:
  • package:get_cli/common/menu/menu.dart that imports:
  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:get_cli/get_cli.dart that imports:
  • package:get_cli/core/generator.dart that imports:
  • package:get_cli/commands/impl/help/help.dart that imports:
  • package:get_cli/commands/commands_list.dart that imports:
  • package:get_cli/commands/impl/commads_export.dart that imports:
  • package:get_cli/commands/impl/sort/sort.dart that imports:
  • package:get_cli/functions/create/create_single_file.dart that imports:
  • package:get_cli/functions/sorter_imports/sort.dart that imports:
  • package:get_cli/common/utils/pubspec/pubspec_utils.dart that imports:
  • package:get_cli/common/menu/menu.dart that imports:
  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:get_cli/get_cli.dart that imports:
  • package:get_cli/core/generator.dart that imports:
  • package:get_cli/commands/impl/help/help.dart that imports:
  • package:get_cli/commands/commands_list.dart that imports:
  • package:get_cli/commands/impl/commads_export.dart that imports:
  • package:get_cli/commands/impl/sort/sort.dart that imports:
  • package:get_cli/functions/create/create_single_file.dart that imports:
  • package:get_cli/functions/sorter_imports/sort.dart that imports:
  • package:get_cli/common/utils/pubspec/pubspec_utils.dart that imports:
  • package:get_cli/common/menu/menu.dart that imports:
  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Linux`.

Because:

  • package:get_cli/get_cli.dart that imports:
  • package:get_cli/core/generator.dart that imports:
  • package:get_cli/commands/impl/help/help.dart that imports:
  • package:get_cli/commands/commands_list.dart that imports:
  • package:get_cli/commands/impl/commads_export.dart that imports:
  • package:get_cli/commands/impl/sort/sort.dart that imports:
  • package:get_cli/functions/create/create_single_file.dart that imports:
  • package:get_cli/functions/sorter_imports/sort.dart that imports:
  • package:get_cli/common/utils/pubspec/pubspec_utils.dart that imports:
  • package:get_cli/common/menu/menu.dart that imports:
  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:get_cli/get_cli.dart that imports:
  • package:get_cli/core/generator.dart that imports:
  • package:get_cli/commands/impl/help/help.dart that imports:
  • package:get_cli/commands/commands_list.dart that imports:
  • package:get_cli/commands/impl/commads_export.dart that imports:
  • package:get_cli/commands/impl/sort/sort.dart that imports:
  • package:get_cli/functions/create/create_single_file.dart that imports:
  • package:get_cli/functions/sorter_imports/sort.dart that imports:
  • package:get_cli/common/utils/pubspec/pubspec_utils.dart that imports:
  • package:get_cli/common/menu/menu.dart that imports:
  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Don't override a method to do a super method invocation with the same parameters.

lib/common/utils/json_serialize/json_ast/tokenize.dart:176:11

    ╷
176 │   int get hashCode => super.hashCode;
    │           ^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/common/utils/json_serialize/json_ast/tokenize.dart

INFO: Don't override a method to do a super method invocation with the same parameters.

lib/common/utils/json_serialize/json_ast/tokenize.dart:207:11

    ╷
207 │   int get hashCode => super.hashCode;
    │           ^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/common/utils/json_serialize/json_ast/tokenize.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor>=2.0.1 <3.0.02.0.12.0.1
cli_dialog>=0.5.0 <1.0.00.5.00.5.0
collection>=1.15.0 <2.0.01.16.01.16.0
dart_style>=2.0.1 <3.0.02.2.32.2.3
http>=0.13.4 <2.0.00.13.50.13.5
intl>=0.17.0 <1.0.00.17.00.17.0
meta>=1.7.0 <2.0.01.8.01.8.0
path>=1.8.0 <2.0.01.8.21.8.2
process_run>=0.12.2 <1.0.00.12.3+20.12.3+2
pubspec>=2.0.1 <3.0.02.3.02.3.0
recase>=4.0.0 <5.0.04.0.04.0.0
version>=2.0.0 <3.0.02.0.33.0.2
yaml>=3.1.0 <4.0.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-44.0.044.0.0
analyzer-4.4.04.4.0
args-2.3.12.3.1
async-2.9.02.9.0
characters-1.2.11.2.1
charcode-1.3.11.3.1
clock-1.1.11.1.1
convert-3.0.23.0.2
crypto-3.0.23.0.2
dart_console-1.1.21.1.2
ffi-2.0.12.0.1
file-6.1.26.1.2
glob-2.1.02.1.0
http_parser-4.0.14.0.1
matcher-0.12.120.12.12
package_config-2.1.02.1.0
pub_semver-2.1.12.1.1
quiver-3.1.03.1.0
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
synchronized-3.0.0+23.0.0+2
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uri-1.0.01.0.0
watcher-1.0.11.0.1
win32-2.7.02.7.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.0.0 <3.0.0` on version does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions version to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.14, Dart 2.17.5.

396
likes
90
pub points
93%
popularity

Publisher

verified publisher icongetx.site

Official CLI for GetX™ framework to build Flutter and Server Applications easily

Homepage

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

ansicolor, cli_dialog, collection, dart_style, http, intl, meta, path, process_run, pubspec, recase, version, yaml

More

Packages that depend on get_cli