frontend_server_client 2.1.0
frontend_server_client: ^2.1.0 copied to clipboard

Client code to start and interact with the frontend_server compiler from the Dart SDK.

1
likes
100 / 130
pub points
98 %
popularity

We analyzed this package on Jun 9, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 32 API elements (96.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:frontend_server_client/frontend_server_client.dart that imports:
  • package:frontend_server_client/src/frontend_server_client.dart that imports:
  • package:frontend_server_client/src/shared.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.5.02.7.02.7.0
path^1.8.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
meta-1.4.01.4.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.17.1, Dart 2.13.1.

1
likes
100
pub points
98%
popularity

Publisher

Unknown

Client code to start and interact with the frontend_server compiler from the Dart SDK.

Documentation

API reference

License

BSD (LICENSE)

Dependencies

async, path

More

Packages that depend on frontend_server_client