flutter_redux_dev_tools 0.4.0
flutter_redux_dev_tools: ^0.4.0 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A Time Traveling Redux Debugger for Flutter

70 / 110
pub points
84 %

We analyzed this package on Mar 1, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 28 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..


371 │     return context.inheritFromWidgetOfExactType(_ContainerState)
    │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_redux_dev_tools.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

flutter_redux>=0.6.0 <
redux>=4.0.0 <
redux_dev_tools>=0.5.0 <
Transitive dependencies

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.6.0 <0.7.0` on flutter_redux does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_redux to update the constraint.

The constraint `>=4.0.0 <5.0.0` on redux does not support the stable version `5.0.0`, that was published 5 days ago.

When redux is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions redux to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.