flutter_github_releases_service 0.5.1
flutter_github_releases_service: ^0.5.1 copied to clipboard

Flutter Android iOS

Use github releases to update the app.

1
likes
85 / 110
pub points
22 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:22:61

   ╷
22 │ <li>Prepare for 1.0.0 version of sensors and package_info. (<a href="http://github.com/amirh/dart_lsc">dart_lsc</a>)</li>
   │                                                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 38 API elements (34.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_github_releases_service/flutter_github_releases_service.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ajanuw_http^0.5.10.5.10.5.1
flutter_downloader^1.5.11.5.21.5.2
install_plugin^2.0.12.0.12.0.1
package_info>=0.4.0+13 <2.0.00.4.3+20.4.3+2
path^1.6.41.7.01.8.0-nullsafety.3
path_provider^1.6.51.6.271.6.27
permission_handler^5.0.1+15.0.1+15.0.1+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
ffi-0.1.30.1.3
file-5.2.15.2.1
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+80.0.4+8
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
permission_handler_platform_interface-2.0.12.0.1
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs