firebase_analytics 7.0.1
firebase_analytics: ^7.0.1 copied to clipboard

Flutter Android iOS web

Flutter plugin for Google Analytics for Firebase, an app measurement solution that provides insight on app usage and user engagement on Android and iOS.

370
likes
110 / 110
pub points
99 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 47 out of 55 API elements (85.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_analytics/firebase_analytics.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_analytics_platform_interface^1.0.11.0.31.1.0
firebase_analytics_web^0.1.00.1.10.2.0
firebase_core^0.7.00.7.01.0.0
flutterflutter0.0.00.0.0
meta^1.0.41.3.0-nullsafety.31.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
firebase-7.3.39.0.0
firebase_core_platform_interface-3.0.14.0.0
firebase_core_web-0.2.1+31.0.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
js-0.6.20.6.3
matcher-0.12.90.12.10
path-1.7.01.8.0
plugin_platform_interface-1.0.32.0.0
quiver-2.1.53.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.0` on firebase_analytics_web does not support the stable version `0.2.0`, that was published 3 days ago.

When firebase_analytics_web is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_analytics_web to update the constraint.

The constraint `^0.7.0` on firebase_core does not support the stable version `1.0.0`, that was published 3 days ago.

When firebase_core is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

370
likes
110
pub points
99%
popularity

Publisher

firebase.google.com

Flutter plugin for Google Analytics for Firebase, an app measurement solution that provides insight on app usage and user engagement on Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

firebase_analytics_platform_interface, firebase_analytics_web, firebase_core, flutter, meta

More

Packages that depend on firebase_analytics