explode_view 1.0.4 icon indicating copy to clipboard operation
explode_view: ^1.0.4 copied to clipboard

A beautiful animation library for Flutter which explodes the image into small particles. This package can be used whenever there is a need of removing the image from the screen.

48
likes
90/ 130
pub points
45%
popularity

We analyzed this package 29 hours ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 85 API elements (18.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
image^2.1.42.1.193.2.0
vector_math^2.0.82.1.22.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.3.1
args-1.6.02.3.1
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.2
crypto-2.1.53.0.2
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
path-1.8.21.8.2
petitparser-3.1.05.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
xml-4.5.16.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.4` on image does not support the stable version `3.0.1`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.3 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.14, Flutter 3.0.4, Dart 2.17.5.

48
likes
90
pub points
45%
popularity

Publisher

verified publisher iconayushagarwal.ml

A beautiful animation library for Flutter which explodes the image into small particles. This package can be used whenever there is a need of removing the image from the screen.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, image, vector_math

More

Packages that depend on explode_view