dropdown_search 0.4.9
dropdown_search: ^0.4.9 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Simple and robust Searchable Dropdown with item search feature, making it possible to use an offline item list or filtering URL for easy customization.

248
likes
100 / 110
pub points
98 %
popularity

We analyzed this package on Mar 9, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 52 out of 75 API elements (69.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/popupMenu.dart:436:20

    ╷
436 │   }) : itemSizes = List<Size>(items.length);
    │                    ^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/popupMenu.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/selectDialog.dart:79:26

   ╷
79 │   final List<T> _items = List<T>();
   │                          ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/selectDialog.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

248
likes
100
pub points
98%
popularity

Simple and robust Searchable Dropdown with item search feature, making it possible to use an offline item list or filtering URL for easy customization.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

salim.lachdhaf@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on dropdown_search