dcli 1.9.6
dcli: ^1.9.6 copied to clipboard

An API and dev environment for writing console (cli) apps/scripts using dart. e.g. allows you to build bash style scripts with dart.

88
likes
120/ 130
pub points
83%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 688 out of 744 API elements (92.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • package:dcli/src/util/stack_trace_impl.dart that imports:
  • package:dcli/src/settings.dart that imports:
  • package:dcli/src/functions/env.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.0.03.1.63.1.6
args^2.0.02.3.02.3.0
async^2.5.02.8.22.8.2
collection^1.15.01.15.01.15.0
crypto^3.0.03.0.13.0.1
csv^5.0.05.0.05.0.0
dart_console^1.0.01.0.01.0.0
equatable^2.0.02.0.32.0.3
ffi^1.1.11.1.21.1.2
file^6.1.06.1.26.1.2
glob^2.0.02.0.22.0.2
ini^2.1.02.1.02.1.0
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
posix^2.1.22.1.22.1.2
pub_semver^2.0.02.1.02.1.0
pubspec^2.0.02.0.12.0.1
uuid^3.0.03.0.53.0.5
validators2^3.0.03.0.03.0.0
win32^2.1.02.2.102.2.10
yaml^3.0.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
basic_utils-3.7.03.7.0
charcode-1.3.11.3.1
convert-3.0.13.0.1
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
logging-1.0.21.0.2
matcher-0.12.110.12.11
pointycastle-3.3.43.3.4
quiver-3.0.1+13.0.1+1
random_string-2.3.12.3.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-1.0.01.0.0
vin_decoder-0.2.1-nullsafety0.2.1-nullsafety

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

88
likes
120
pub points
83%
popularity

Publisher

noojee.dev

An API and dev environment for writing console (cli) apps/scripts using dart. e.g. allows you to build bash style scripts with dart.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

archive, args, async, collection, crypto, csv, dart_console, equatable, ffi, file, glob, ini, meta, path, posix, pub_semver, pubspec, uuid, validators2, win32, yaml

More

Packages that depend on dcli