build 2.1.1
build: ^2.1.1 copied to clipboard

A package for authoring build_runner compatible code generators.

32
likes
120/ 130
pub points
99%
popularity

We analyzed this package 45 hours ago, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/readme.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 92 out of 152 API elements (60.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=1.5.0 <3.0.02.8.02.8.0
async^2.5.02.8.22.8.2
convert^3.0.03.0.13.0.1
crypto^3.0.03.0.13.0.1
glob^2.0.02.0.22.0.2
logging^1.0.01.0.21.0.2
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.031.0.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
file-6.1.26.1.2
package_config-2.0.22.0.2
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.15.0.

32
likes
120
pub points
99%
popularity

Publisher

dart.dev

A package for authoring build_runner compatible code generators.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, async, convert, crypto, glob, logging, meta, path

More

Packages that depend on build