bloc_rest_api 0.4.0+1
bloc_rest_api: ^0.4.0+1 copied to clipboard

A generic bloc package to implement REST APIs easily in flutter.

31
likes
90/ 130
pub points
45%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 48 API elements (64.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:bloc_rest_api/bloc_rest_api.dart that imports:
  • package:bloc_rest_api/src/cubits/cubits.dart that imports:
  • package:hydrated_bloc/hydrated_bloc.dart that imports:
  • package:hydrated_bloc/src/hydrated_storage.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because every version of flutter_test from sdk depends on test_api 0.4.2 and mockito >=4.1.2 <=5.0.0-nullsafety.7 depends on test_api ^0.2.19-nullsafety, flutter_test from sdk is incompatible wit[...]
So, because bloc_rest_api depends on both flutter_test any from sdk and mockito ^4.1.3, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

31
likes
90
pub points
45%
popularity

A generic bloc package to implement REST APIs easily in flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, flutter, flutter_bloc, http, hydrated_bloc, meta

More

Packages that depend on bloc_rest_api