angular_redux 1.3.0
angular_redux: ^1.3.0 copied to clipboard

Dart js
Flutter web

Bindings to use Redux state management with Angular Dart components

4
likes
80 / 110
pub points
27 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 5 API elements (20.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:angular_redux/angular_redux.dart that imports:
  • package:angular_redux/src/select_pipe.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/platform/browser/tools/tools.dart that imports:
  • package:angular/src/platform/browser/tools/common_tools.dart that imports:
  • package:angular/src/core/linker/component_factory.dart that imports:
  • package:angular/src/core/linker/view_ref.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/select_pipe.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular>=4.0.0 <6.0.05.3.16.0.1
redux>=3.0.0 <5.0.04.0.0+35.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.35.41.1.0
angular_ast-0.5.91.0.1
angular_compiler-0.4.31.0.1
args-1.6.02.0.0
async-2.5.02.5.0
build-1.6.21.6.3
build_config-0.4.60.4.6
built_collection-5.0.05.0.0
built_value-8.0.08.0.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
code_builder-3.6.03.6.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
csslib-0.14.6+10.17.0
dart_style-1.2.41.3.14
file-5.2.16.1.0
fixnum-1.0.01.0.0
front_end-0.1.140.1.29
glob-1.2.02.0.0
intl-0.15.80.17.0
js-0.6.30.6.3
json_annotation-4.0.04.0.0
kernel-0.3.140.3.29
logging-0.11.41.0.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
source_gen-0.9.4+40.9.10+3
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=4.0.0 <6.0.0` on angular does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions angular to update the constraint.

The constraint `>=3.0.0 <5.0.0` on redux does not support the stable version `5.0.0`, that was published 8 days ago.

When redux is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions redux to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Dart 2.12.0.

4
likes
80
pub points
27%
popularity

Bindings to use Redux state management with Angular Dart components

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ranquild@gmail.com

License

MIT (LICENSE)

Dependencies

angular, redux

More

Packages that depend on angular_redux