webdriver 3.0.0
webdriver: ^3.0.0 copied to clipboard

Provides WebDriver bindings for Dart. Supports WebDriver JSON interface and W3C spec. Requires the use of WebDriver remote server.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add webdriver

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  webdriver: ^3.0.0

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:webdriver/async_core.dart';
import 'package:webdriver/async_html.dart';
import 'package:webdriver/async_io.dart';
import 'package:webdriver/core.dart';
import 'package:webdriver/io.dart';
import 'package:webdriver/support/async.dart';
import 'package:webdriver/support/firefox_profile.dart';
import 'package:webdriver/support/stdio_stepper.dart';
import 'package:webdriver/sync_core.dart';
import 'package:webdriver/sync_io.dart';
15
likes
80
pub points
98%
popularity

Publisher

google.dev

Provides WebDriver bindings for Dart. Supports WebDriver JSON interface and W3C spec. Requires the use of WebDriver remote server.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

archive, matcher, path, stack_trace, sync_http

More

Packages that depend on webdriver