kiwi 4.0.1
kiwi: ^4.0.1 copied to clipboard

A simple yet efficient dependency injection container for Dart and Flutter (can be coupled with the kiwi_generator package).

[4.0.1] - 2021-10-13 #

Fixed #

  • Dart constraint issue for kiwi

[4.0.0] - 2021-10-13 #

BREAKING #

  • Support for kiwi_generator 4.0.0
  • Dart 2.14 min requirement

Updated dependencies #

[3.0.0] - 2021-06-01 #

Added #

  • Nullsafety codebase migration

Updated dependencies #

  • Updated dependencies to make sure we can still build with new dependencies.

[2.1.1] - 2020-10-24 #

Updated #

  • Description to make the kiwi package easy to find in pub.flutter-io.cn

[2.1.0] - 2020-10-24 #

Added #

  • No response bot to git
  • Android v2 embedding for the example project

[2.0.1] #

Updated #

  • Updated dependencies

[2.0.0] #

BREAKING CHANGE #

  • #9 Removed the unused T generic for some functions

[1.1.0] #

Added #

  • #34 resolveAs<S,T>() added for testing only

Updated #

  • #32 better error handling
  • Flutter example improvements
  • Updated documentation

[1.0.0] #

BREAKING CHANGE #

  • renamed Container to KiwiContainer so it is easier for Flutter devs to import the KiwiContainer

[0.3.3] #

Fixed #

  • Updated homepage

[0.3.2] #

Fixed #

  • Fixed pub.flutter-io.cn score

[0.3.1] #

Fixed #

  • Fixed pub.flutter-io.cn score

[0.3.0] #

Fixed #

  • Upgrade dependencies
  • Fixed formatting errors
  • Fixed pub.flutter-io.cn score

[0.2.0] #

Added #

  • Scoped constructor for the Container class.
  • Upgrade test dependency

[0.1.0] #

  • Initial Open Source release.
92
likes
130
pub points
95%
popularity

Publisher

vanlooverenkoen.be

A simple yet efficient dependency injection container for Dart and Flutter (can be coupled with the kiwi_generator package).

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta

More

Packages that depend on kiwi