firebase_dart_ui 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 36

firebase_dart_ui #

A dart wrapper for https://github.com/firebase/firebaseui-web. FirebaseUI is a Javascript library maintained by the Firebase team that provides sign on flows. This library provides a Dart wrapper around FirebaseUI as an Angular component.

A demo app is hosted online here

The Angular component <firebase-auth-ui> will handle Firebase Authentication for your application.

The component is visible when the user has not been authenticated. It presents a dialog with the various social login and email providers that have been configured. Once the user has authenticated, the components display attribute is set to none. Embed this component on your landing page for your SPA application.

Important #

You must add these lines to your index.html <head> section:

<script src="https://www.gstatic.com/firebasejs/4.8.0/firebase.js"></script>
<script src="https://cdn.firebase.com/libs/firebaseui/2.5.1/firebaseui.js"></script>
<link type="text/css" rel="stylesheet" href="https://cdn.firebase.com/libs/firebaseui/2.5.1/firebaseui.css" />

See the example/ application.

Running the demo #

With DDC:

cd example
pub serve
# open localhost:8080

To use your our own Firebase project to test, you must edit main.dart and enter in your project credentials. Also edit example/.firebaserc and enter your project name.

Build and deploy the example:

cd example
pub build
firebase deploy

Known Issues #

  • The provider implementations need to be fleshed out (phone provider, for example)
  • The signInSuccess callback does not get invoked. JS interop issue. Suggestions welcome.

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_dart_ui: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_dart_ui/firebase_dart_ui.dart';
  
Version Uploaded Documentation Archive
0.1.1 Oct 25, 2018 Go to the documentation of firebase_dart_ui 0.1.1 Download firebase_dart_ui 0.1.1 archive
0.1.0 Aug 10, 2018 Go to the documentation of firebase_dart_ui 0.1.0 Download firebase_dart_ui 0.1.0 archive
0.0.3 Mar 4, 2018 Go to the documentation of firebase_dart_ui 0.0.3 Download firebase_dart_ui 0.0.3 archive
0.0.2 Feb 15, 2018 Go to the documentation of firebase_dart_ui 0.0.2 Download firebase_dart_ui 0.0.2 archive
0.0.1 Jan 7, 2018 Go to the documentation of firebase_dart_ui 0.0.1 Download firebase_dart_ui 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.15.0 <2.0.0