A demo app is hosted online here
The Angular component
<firebase-auth-ui> will handle
Firebase Authentication for your application.
The component is visible when the user has not been authenticated. It presents a dialog with
the various social login and email providers that have been configured. Once the user
has authenticated, the components display attribute is set to
none. Embed this component
on your landing page for your SPA application.
You must add these lines to your index.html
<script src="https://www.gstatic.com/firebasejs/4.8.0/firebase.js"></script> <script src="https://cdn.firebase.com/libs/firebaseui/2.5.1/firebaseui.js"></script> <link type="text/css" rel="stylesheet" href="https://cdn.firebase.com/libs/firebaseui/2.5.1/firebaseui.css" />
See the example/ application.
cd example pub serve # open localhost:8080
To use your our own Firebase project to test, you must edit main.dart and enter in your project credentials. Also edit example/.firebaserc and enter your project name.
Build and deploy the example:
cd example pub build firebase deploy
Add this to your package's pubspec.yaml file:
dependencies: firebase_dart_ui: ^0.0.1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.1||Oct 25, 2018|
|0.1.0||Aug 10, 2018|
|0.0.3||Mar 4, 2018|
|0.0.2||Feb 15, 2018|
|0.0.1||Jan 7, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=2.0.0-dev.15.0 <2.0.0|