email_validator 1.0.6
email_validator: ^1.0.6 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

A simple (but correct) dart class for validating email addresses

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  email_validator: ^1.0.6

2. Install it

You can install packages from the command line:

with pub:

$ dart pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:email_validator/email_validator.dart';
258
likes
110
pub points
98%
popularity

A simple (but correct) dart class for validating email addresses

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

fredrik.eilertsen@gmail.com

License

MIT (LICENSE)

More

Packages that depend on email_validator