web_browser 0.5.0 icon indicating copy to clipboard operation
web_browser: ^0.5.0 copied to clipboard

A cross-platform Flutter widget for displaying websites and other web content. Has optional navigation buttons.

57
likes
120/ 140
pub points
90%
popularity

We analyzed this package 39 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 54 out of 86 API elements (62.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/platform_interface.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/platform_interface.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/platform_interface.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:web_browser/web_browser.dart that imports:
  • package:web_browser/src/web_browser.dart that imports:
  • package:web_browser/src/web_browser_impl_default.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_android_cookie_manager.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: The import of 'web_browser_impl_default.dart' is unnecessary because all of the used elements are also provided by the import of 'package:web_browser/web_browser.dart'.

lib/src/web_browser.dart:22:8

   ╷
22 │ import 'web_browser_impl_default.dart'
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/web_browser.dart

INFO: Don't use web-only libraries outside Flutter web plugin packages.

lib/src/web_browser_impl_browser.dart:16:1

   ╷
16 │ import 'dart:html' as html;
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/web_browser_impl_browser.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
csp^0.1.10.1.10.1.1
cupertino_icons^1.0.21.0.51.0.5
flutterflutter0.0.00.0.0
meta^1.3.01.8.01.9.0
share^2.0.02.0.42.0.4
universal_html^2.0.02.0.82.0.8
web_node^0.2.00.2.10.2.1
webview_flutter^2.0.02.8.04.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.17.01.17.1
crypto-3.0.23.0.2
csslib-0.17.20.17.2
fixnum-1.1.01.1.0
html-0.15.10.15.1
js-0.6.50.6.7
kind-0.5.20.5.2
material_color_utilities-0.2.00.2.0
mime-1.0.41.0.4
path-1.8.31.8.3
plugin_platform_interface-2.1.32.1.3
protobuf-2.1.02.1.0
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
universal_io-2.0.42.0.4
vector_math-2.1.42.1.4
webview_flutter_android-2.10.43.2.4
webview_flutter_platform_interface-1.9.52.0.1
webview_flutter_wkwebview-2.9.53.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on webview_flutter does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

57
likes
120
pub points
90%
popularity

Publisher

verified publisher icondint.dev

A cross-platform Flutter widget for displaying websites and other web content. Has optional navigation buttons.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

csp, cupertino_icons, flutter, meta, share, universal_html, web_node, webview_flutter

More

Packages that depend on web_browser