web3dart 2.0.0-dev.3
web3dart: ^2.0.0-dev.3 copied to clipboard

Dart native js
Flutter Android iOS web

Dart library to connect to Ethereum clients. Send transactions and interact with smart contracts!

38
likes
95 / 110
pub points
88 %
popularity

We analyzed this package on Dec 27, 2020, and awarded it 95 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:67:1

   ╷
67 │ <a href="http://truffleframework.com/">truffle</a> and <a href="http://truffleframework.com/ganache/">ganache</a>. All these options will give you
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 261 out of 371 API elements (70.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.1.12.1.12.1.1
http^0.12.00.12.20.12.2
isolate^2.0.02.0.32.0.3
json_rpc_2^2.1.02.2.22.2.2
meta^1.1.01.2.41.2.4
pointycastle^1.0.11.0.22.0.0
stream_channel^2.0.02.0.02.0.0
typed_data^1.1.61.2.01.2.0
uuid^2.0.02.2.22.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
charcode-1.1.31.1.3
collection-1.14.131.14.13
crypto-2.1.52.1.5
http_parser-3.1.43.1.4
pedantic-1.9.21.9.2
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on pointycastle does not support the latest published version `2.0.0`

pubspec.yaml:10:17

   ╷
10 │   pointycastle: ^1.0.1
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

38
likes
95
pub points
88%
popularity

Publisher

simonbinder.eu

Dart library to connect to Ethereum clients. Send transactions and interact with smart contracts!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

convert, http, isolate, json_rpc_2, meta, pointycastle, stream_channel, typed_data, uuid

More

Packages that depend on web3dart