vendor 0.9.1 icon indicating copy to clipboard operation
vendor: ^0.9.1 copied to clipboard

SDKDart

Utility for vendoring packages into a project and rewriting import/export statements.

3
likes
110/ 130
pub points
4%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Binary only

Cannot assign platform tags, it is a binary only package

icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=2.7.0 <5.0.04.2.04.2.0
args^2.3.02.3.12.3.1
async^2.8.22.9.02.9.0
checked_yaml^2.0.12.0.12.0.1
glob^2.0.22.1.02.1.0
http^0.13.40.13.40.13.4
io^1.0.31.0.31.0.3
json_annotation^4.3.04.5.04.5.0
logging^1.0.21.0.21.0.2
meta^1.7.01.8.01.8.0
path^1.8.01.8.21.8.2
pub_semver^2.1.02.1.12.1.1
pubspec_parse^1.2.01.2.01.2.0
retry^3.1.03.1.03.1.0
tar^0.5.10.5.5+10.5.5+1
yaml^3.1.03.1.13.1.1
yaml_edit^2.0.12.0.32.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-41.0.041.0.0
collection-1.16.01.16.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
file-6.1.26.1.2
http_parser-4.0.14.0.1
package_config-2.1.02.1.0
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.11.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Dart 2.17.5.

3
likes
110
pub points
4%
popularity

Publisher

verified publisher icongoogle.dev

Utility for vendoring packages into a project and rewriting import/export statements.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

analyzer, args, async, checked_yaml, glob, http, io, json_annotation, logging, meta, path, pub_semver, pubspec_parse, retry, tar, yaml, yaml_edit

More

Packages that depend on vendor