usage 4.1.0 icon indicating copy to clipboard operation
usage: ^4.1.0 copied to clipboard

A Google Analytics wrapper for command-line, web, and Flutter apps.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add usage

With Flutter:

 $ flutter pub add usage

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  usage: ^4.1.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:usage/usage.dart';
58
likes
140
pub points
99%
popularity

Publisher

verified publisher icontools.dart.dev

A Google Analytics wrapper for command-line, web, and Flutter apps.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

meta, path

More

Packages that depend on usage