large Flutter Favorite logosmall Flutter Favorite logo

url_launcher 6.1.4 icon indicating copy to clipboard operation
url_launcher: ^6.1.4 copied to clipboard

Flutter plugin for launching a URL. Supports web, phone, SMS, and email schemes.

4549
likes
130/ 130
pub points
100%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 35 API elements (88.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
url_launcher_android^6.0.136.0.176.0.17
url_launcher_ios^6.0.136.0.176.0.17
url_launcher_linux>=2.0.0 <4.0.03.0.13.0.1
url_launcher_macos>=2.0.0 <4.0.03.0.13.0.1
url_launcher_platform_interface^2.1.02.1.02.1.0
url_launcher_web^2.0.02.0.122.0.12
url_launcher_windows>=2.0.0 <4.0.03.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
flutter_web_plugins-0.0.00.0.0
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
plugin_platform_interface-2.1.22.1.2
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.