upgrader 5.0.0 icon indicating copy to clipboard operation
upgrader: ^5.0.0 copied to clipboard

Flutter package for prompting users to upgrade when there is a newer version of the app in the store.

1084
likes
140/ 140
pub points
99%
popularity

We analyzed this package 8 hours ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 132 out of 232 API elements (56.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform Android.

Because:

  • package:upgrader/upgrader.dart that imports:
  • package:upgrader/src/upgrader.dart that imports:
  • package:upgrader/src/appcast.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package does not support platform iOS.

Because:

  • package:upgrader/upgrader.dart that imports:
  • package:upgrader/src/upgrader.dart that imports:
  • package:upgrader/src/appcast.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package does not support platform Linux.

Because:

  • package:upgrader/upgrader.dart that imports:
  • package:upgrader/src/upgrader.dart that imports:
  • package:upgrader/src/appcast.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package does not support platform macOS.

Because:

  • package:upgrader/upgrader.dart that imports:
  • package:upgrader/src/upgrader.dart that imports:
  • package:upgrader/src/appcast.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package not compatible with platform Web

Because:

  • package:upgrader/upgrader.dart that imports:
  • package:upgrader/src/upgrader.dart that imports:
  • package:upgrader/src/appcast.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_linux.dart that imports:
  • package:file/local.dart that imports:
  • package:file/src/backends/local.dart that imports:
  • package:file/src/backends/local/local_file_system.dart that imports:
  • package:file/src/backends/local/local_link.dart that imports:
  • package:file/src/backends/local/local_file_system_entity.dart that imports:
  • package:file/src/backends/local/local_file.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info_plus^8.0.08.0.08.0.0
flutterflutter0.0.00.0.0
html^0.15.10.15.10.15.1
http^0.13.50.13.50.13.5
os_detect^2.0.12.0.12.0.1
package_info_plus^3.0.13.0.23.0.2
shared_preferences^2.0.152.0.152.0.15
url_launcher^6.1.66.1.76.1.7
version^3.0.23.0.23.0.2
xml^6.1.06.1.06.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.16.01.17.0
csslib-0.17.20.17.2
device_info_plus_platform_interface-7.0.07.0.0
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.24.0.2
js-0.6.40.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
package_info_plus_platform_interface-2.0.12.0.1
path-1.8.31.8.3
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
petitparser-5.1.05.1.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
shared_preferences_android-2.0.142.0.14
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
url_launcher_android-6.0.226.0.22
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.12.1.1
url_launcher_web-2.0.132.0.13
url_launcher_windows-3.0.13.0.1
vector_math-2.1.22.1.4
win32-3.1.23.1.2
xdg_directories-0.2.0+20.2.0+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

1084
likes
140
pub points
99%
popularity

Publisher

verified publisher iconlarryaasen.com

Flutter package for prompting users to upgrade when there is a newer version of the app in the store.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

device_info_plus, flutter, html, http, os_detect, package_info_plus, shared_preferences, url_launcher, version, xml

More

Packages that depend on upgrader