universal_io 2.0.4 icon indicating copy to clipboard operation
universal_io: ^2.0.4 copied to clipboard

Cross-platform 'dart:io' that works in all platforms (browsers, Flutter, and VM).

150
likes
130/ 140
pub points
98%
popularity

We analyzed this package 16 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected licenses: Apache-2.0, BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 22 API elements (95.5 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 32 issues. Showing the first 2:

INFO: The import of 'http_status_codes.dart' is unnecessary because all of the used elements are also provided by the import of '../io_impl_js.dart'.

lib/src/http/http.dart:58:8

   ╷
58 │ import 'http_status_codes.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/http/http.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/http/http.dart:79:16

   ╷
79 │   static final TEXT = text;
   │                ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/http/http.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.17.01.17.0
crypto^3.0.03.0.23.0.2
meta^1.3.01.8.01.8.0
typed_data^1.3.01.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Dart 2.18.4.

150
likes
130
pub points
98%
popularity

Publisher

verified publisher icondint.dev

Cross-platform 'dart:io' that works in all platforms (browsers, Flutter, and VM).

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0, BSD-3-Clause (LICENSE)

Dependencies

collection, crypto, meta, typed_data

More

Packages that depend on universal_io