universal_io 2.0.4 icon indicating copy to clipboard operation
universal_io: ^2.0.4 copied to clipboard

Cross-platform 'dart:io' that works in all platforms (browsers, Flutter, and VM).

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add universal_io

With Flutter:

 $ flutter pub add universal_io

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  universal_io: ^2.0.4

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:universal_io/io.dart';
import 'package:universal_io/prefer_sdk/io.dart';
import 'package:universal_io/prefer_universal/io.dart';
150
likes
130
pub points
98%
popularity

Publisher

verified publisher icondint.dev

Cross-platform 'dart:io' that works in all platforms (browsers, Flutter, and VM).

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0, BSD-3-Clause (LICENSE)

Dependencies

collection, crypto, meta, typed_data

More

Packages that depend on universal_io