test_api 0.4.14 icon indicating copy to clipboard operation
test_api: ^0.4.14 copied to clipboard

A library for writing Dart tests.

9
likes
110/ 140
pub points
99%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 168 out of 198 API elements (84.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

INFO: 'formatFailure' is deprecated and shouldn't be used. Will be removed in 0.13.0..

lib/src/expect/async_matcher.dart:41:16

   ╷
41 │           fail(formatFailure(this, item, realResult as String));
   │                ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/expect/async_matcher.dart

INFO: 'ErrorFormatter' is deprecated and shouldn't be used. Will be removed in 0.13.0..

lib/src/expect/expect.dart:45:47

   ╷
45 │     @Deprecated('Will be removed in 0.13.0.') ErrorFormatter? formatter}) {
   │                                               ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/expect/expect.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.5.02.9.02.9.0
boolean_selector^2.1.02.1.02.1.0
collection^1.15.01.16.01.16.0
matcher>=0.12.11 <0.12.130.12.120.12.12
meta^1.3.01.8.01.8.0
source_span^1.8.01.9.11.9.1
stack_trace^1.10.01.10.01.10.0
stream_channel^2.1.02.1.12.1.1
string_scanner^1.1.01.1.11.1.1
term_glyph^1.2.01.2.11.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
path-1.8.21.8.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.18, Dart 2.18.2.