stacked_services 0.9.8 icon indicating copy to clipboard operation
stacked_services: ^0.9.8 copied to clipboard

A package that contains some default implementations of services required for a cleaner implementation of the Stacked Architecture.

235
likes
130/ 140
pub points
97%
popularity

We analyzed this package 8 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 81 out of 209 API elements (38.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

INFO: 'customData' is deprecated and shouldn't be used. Prefer to use data and pass in a generic type..

lib/src/bottom_sheet/bottom_sheet_service.dart:140:13

    ╷
140 │             customData: customData,
    │             ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bottom_sheet/bottom_sheet_service.dart

INFO: The import of 'package:flutter/cupertino.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/src/dialog/dialog_service.dart:3:8

  ╷
3 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dialog/dialog_service.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^3.0.13.0.23.0.2
flutterflutter0.0.00.0.0
get^4.5.14.6.54.6.5
stacked_core^1.2.21.2.41.2.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.16.01.17.0
get_it-7.2.07.2.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.22, Flutter 3.3.9, Dart 2.18.5.

235
likes
130
pub points
97%
popularity

Publisher

verified publisher iconfilledstacks.com

A package that contains some default implementations of services required for a cleaner implementation of the Stacked Architecture.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

crypto, flutter, get, stacked_core

More

Packages that depend on stacked_services