sqflite_common 1.0.2+1

Dart native js
Flutter Android iOS web

Dart wrapper on SQLite, a self-contained, high-reliability, embedded, SQL database engine.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  sqflite_common: ^1.0.2+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:sqflite_common/sqflite_dev.dart';
import 'package:sqflite_common/sql.dart';
import 'package:sqflite_common/sqlite_api.dart';
import 'package:sqflite_common/utils/utils.dart';
12
likes
110
pub points
100%
popularity

Dart wrapper on SQLite, a self-contained, high-reliability, embedded, SQL database engine.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alex@tekartik.com

License

MIT (LICENSE)

Dependencies

meta, path, synchronized

More

Packages that depend on sqflite_common