source_helper 1.3.0
source_helper: ^1.3.0 copied to clipboard

Utilities to help with Dart source code generation. Includes utilities for properly generating String literals from any String value.

9
likes
120/ 130
pub points
98%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 14 API elements (64.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=1.3.0 <3.0.02.6.02.6.0
collection^1.15.01.15.01.15.0
source_gen^1.0.01.1.11.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-29.0.029.0.0
args-2.3.02.3.0
async-2.8.22.8.2
build-2.1.12.1.1
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.2.02.2.0
file-6.1.26.1.2
glob-2.0.22.0.2
logging-1.0.21.0.2
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

9
likes
120
pub points
98%
popularity

Publisher

google.dev

Utilities to help with Dart source code generation. Includes utilities for properly generating String literals from any String value.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

analyzer, collection, source_gen

More

Packages that depend on source_helper