sentry_link 0.0.3 icon indicating copy to clipboard operation
sentry_link: ^0.0.3 copied to clipboard

Automatic capture of exceptions and GraphQL errors for the gql eco-system, like graphql and ferry

0
likes
120/ 140
pub points
68%
popularity

We analyzed this package 2 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 7 API elements (28.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/sentry_link.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
gql^0.13.00.13.10.14.0
gql_error_link^0.2.00.2.20.2.3
gql_exec^0.4.00.4.00.4.1
gql_link^0.4.00.4.20.5.0
sentry^6.4.06.11.26.11.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
clock-1.1.11.1.1
collection-1.16.01.16.0
crypto-3.0.23.0.2
http-0.13.50.13.5
http_parser-4.0.14.0.1
intl-0.17.00.17.0
meta-1.8.01.8.0
path-1.8.21.8.2
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-3.0.63.0.6

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.0` on gql does not support the stable version `0.14.0`.

Try running dart pub upgrade --major-versions gql to update the constraint.

The constraint `^0.4.0` on gql_link does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions gql_link to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.18, Dart 2.18.2.

0
likes
120
pub points
68%
popularity

Publisher

verified publisher iconuekoetter.dev

Automatic capture of exceptions and GraphQL errors for the gql eco-system, like graphql and ferry

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

gql, gql_error_link, gql_exec, gql_link, sentry

More

Packages that depend on sentry_link