quick_log 1.1.3

Dart native js
Flutter Android iOS web

An easy to use and extendable logging package for Dart. Especially useful for use in libraries, as it allows applications to control logging from the imported libraries.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  quick_log: ^1.1.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:quick_log/quick_log.dart';
6
likes
110
pub points
89%
popularity

Publisher

muha.dev

An easy to use and extendable logging package for Dart. Especially useful for use in libraries, as it allows applications to control logging from the imported libraries.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

no_bloc, path, rxdart

More

Packages that depend on quick_log