puppeteer 2.4.0
puppeteer: ^2.4.0 copied to clipboard

A high-level API to control headless Chrome over the DevTools Protocol. This is a port of Puppeteer in Dart.

139
likes
120/ 130
pub points
88%
popularity

We analyzed this package 37 hours ago, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2921 out of 6974 API elements (41.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:puppeteer/puppeteer.dart that imports:
  • package:puppeteer/src/target.dart that imports:
  • package:puppeteer/src/page/worker.dart that imports:
  • package:puppeteer/src/page/execution_context.dart that imports:
  • package:puppeteer/src/page/page.dart that imports:
  • package:puppeteer/src/page/tracing.dart that imports:
  • package:puppeteer/protocol/io.dart that imports:
  • package:puppeteer/protocol/runtime.dart that imports:
  • package:puppeteer/src/connection.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.0.03.1.63.1.6
async^2.5.02.8.22.8.2
collection^1.15.01.15.01.15.0
http^0.13.00.13.40.13.4
logging^1.0.01.0.21.0.2
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
petitparser^4.1.04.4.04.4.0
pool^1.5.01.5.01.5.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
http_parser-4.0.04.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

139
likes
120
pub points
88%
popularity

Publisher

xaha.dev

A high-level API to control headless Chrome over the DevTools Protocol. This is a port of Puppeteer in Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

archive, async, collection, http, logging, meta, path, petitparser, pool

More

Packages that depend on puppeteer