protoc_plugin 19.0.1

Dart native
Flutter Android iOS

Protoc compiler plugin to generate Dart code

5
likes
75 / 110
pub points
89 %
popularity

We analyzed this package on Sep 18, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:92:9

   ╷
92 │ <li>Mac <a href="http://brew.sh/">homebrew</a>: <code>brew install protobuf</code></li>
   │         ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 141 out of 321 API elements (43.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:protoc_plugin/bazel.dart that imports:
  • package:protoc_plugin/protoc.dart that imports:
  • package:dart_style/dart_style.dart that imports:
  • package:dart_style/src/exceptions.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/sdk.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/util/comment.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/dart/constant/evaluation.dart that imports:
  • package:analyzer/src/generated/constant.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/element/type_schema_elimination.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/lazy_ast.dart that imports:
  • package:analyzer/src/summary2/linked_unit_context.dart that imports:
  • package:analyzer/src/summary2/linked_bundle_context.dart that imports:
  • package:analyzer/src/summary2/linked_element_factory.dart that imports:
  • package:analyzer/src/dart/analysis/session.dart that imports:
  • package:analyzer/src/dart/element/inheritance_manager3.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dart_style^1.0.61.3.71.3.7
fixnum^0.10.90.10.110.10.11
path^1.0.01.7.01.7.0
protobuf>=0.14.4 <2.0.01.0.11.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-9.0.09.0.0
analyzer-0.40.20.40.2
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
glob-1.2.01.2.0
js-0.6.20.6.2
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs