pedantic 1.10.0-nullsafety
pedantic: ^1.10.0-nullsafety copied to clipboard

The Dart analyzer settings and best practices used internally at Google.

283
likes
50 / 110
pub points
100 %
popularity

We analyzed this package on Dec 26, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:9:8

  ╷
9 │   sdk: '>=2.10.0-0 <2.10.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.12.0-133.2.beta. Cannot run `pub outdated`.

pubspec.yaml:9:8

  ╷
9 │   sdk: '>=2.10.0-0 <2.10.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 2.12.0-133.2.beta.

pubspec.yaml:9:8

  ╷
9 │   sdk: '>=2.10.0-0 <2.10.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (2.12.0)

pubspec.yaml:9:8

  ╷
9 │   sdk: '>=2.10.0-0 <2.10.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵
Support sound null-safety
0 / 0

0/0 points: Unable to detect null safety

Package resolution failed. Could not determine null-safety.

Run pub get for more information.

283
likes
50
pub points
100%
popularity

Publisher

google.dev

The Dart analyzer settings and best practices used internally at Google.

Repository (GitHub)
View/report issues

License

BSD (LICENSE)

More

Packages that depend on pedantic