paulonia_error_service 0.4.0 icon indicating copy to clipboard operation
paulonia_error_service: ^0.4.0 copied to clipboard

Flutter package that wraps the Catcher package. Package with functions for get the configurations for Catcher and a function to send an error.

2
likes
130/ 140
pub points
35%
popularity

We analyzed this package 8 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 12 API elements (25.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:paulonia_error_service/paulonia_error_service.dart that imports:
  • package:paulonia_utils/paulonia_utils.dart that imports:
  • package:paulonia_utils/paulonia_utils_mobile.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:paulonia_error_service/paulonia_error_service.dart that imports:
  • package:paulonia_utils/paulonia_utils.dart that imports:
  • package:paulonia_utils/paulonia_utils_mobile.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:paulonia_error_service/paulonia_error_service.dart that imports:
  • package:paulonia_utils/paulonia_utils.dart that imports:
  • package:paulonia_utils/paulonia_utils_mobile.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Web`.

Because:

  • package:paulonia_error_service/paulonia_error_service.dart that imports:
  • package:catcher/catcher.dart that imports:
  • package:catcher/handlers/email_manual_handler.dart that imports:
  • package:flutter_mailer/flutter_mailer.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
catcher^0.6.90.6.90.7.0
flutterflutter0.0.00.0.0
paulonia_utils^0.3.00.3.00.4.0
sentry^6.3.06.19.06.19.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.17.01.17.0
connectivity-3.0.63.0.6
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
crypto-3.0.23.0.2
device_info-2.0.32.0.3
device_info_platform_interface-2.0.12.0.1
device_info_plus-3.2.48.0.0
device_info_plus_linux-2.1.15.0.0
device_info_plus_macos-2.2.35.0.0
device_info_plus_platform_interface-2.6.17.0.0
device_info_plus_web-2.1.05.0.0
device_info_plus_windows-2.1.16.0.0
dio-4.0.64.0.6
ffi-1.2.12.0.1
file-6.1.46.1.4
flutter_mailer-2.0.22.0.2
flutter_web_plugins-0.0.00.0.0
fluttertoast-8.1.28.1.2
http-0.13.50.13.5
http_parser-4.0.24.0.2
intl-0.17.00.18.0
js-0.6.50.6.6
logging-1.1.01.1.0
mailer-5.3.06.0.0
material_color_utilities-0.2.00.2.0
meta-1.8.01.8.0
mime-1.0.41.0.4
ntp-2.0.02.0.0
package_info_plus-1.4.23.0.2
package_info_plus_linux-1.0.52.0.0
package_info_plus_macos-1.3.02.0.0
package_info_plus_platform_interface-1.0.22.0.1
package_info_plus_web-1.0.62.0.0
package_info_plus_windows-1.0.53.0.0
path-1.8.31.8.3
pedantic-1.11.11.11.1
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
universal_io-2.0.42.0.4
uuid-3.0.73.0.7
vector_math-2.1.42.1.4
win32-2.6.14.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.9` on catcher does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions catcher to update the constraint.

The constraint `^0.3.0` on paulonia_utils does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions paulonia_utils to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

2
likes
130
pub points
35%
popularity

Publisher

verified publisher iconpaulonia.dev

Flutter package that wraps the Catcher package. Package with functions for get the configurations for Catcher and a function to send an error.

Homepage
Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

catcher, flutter, paulonia_utils, sentry

More

Packages that depend on paulonia_error_service