pageloader 4.0.0
pageloader: ^4.0.0 copied to clipboard

Supports the creation of page objects that can be shared between in-browser tests and WebDriver tests.

2
likes
90/ 130
pub points
52%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 327 out of 564 API elements (58.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.7.11.7.22.3.0
build^2.0.22.1.02.1.0
build_config^1.0.01.0.01.0.0
built_value^8.0.68.1.28.1.2
collection^1.15.01.15.01.15.0
js^0.6.30.6.30.6.3
matcher^0.12.100.12.110.12.11
quiver^3.0.13.0.13.0.1
source_gen^1.0.11.0.31.1.0
webdriver^3.0.03.0.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.026.0.0
archive-3.1.23.1.2
args-2.3.02.3.0
async-2.8.22.8.2
built_collection-5.1.15.1.1
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
cli_util-0.3.30.3.3
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.1.02.1.0
file-6.1.26.1.2
fixnum-1.0.01.0.0
glob-2.0.12.0.1
json_annotation-4.1.04.1.0
logging-1.0.21.0.2
meta-1.7.01.7.0
package_config-2.0.22.0.2
pedantic-1.11.11.11.1
pub_semver-2.1.02.1.0
pubspec_parse-1.1.01.1.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
sync_http-0.3.00.3.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.7.1` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • package:pageloader/builder.dart that imports:
  • package:pageloader/src/generators/pageobject_generator.dart where package:pageloader/src/generators/pageobject_generator.dart is opting out from null safety.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.1+1, Dart 2.14.1.

2
likes
90
pub points
52%
popularity

Supports the creation of page objects that can be shared between in-browser tests and WebDriver tests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

analyzer, build, build_config, built_value, collection, js, matcher, quiver, source_gen, webdriver

More

Packages that depend on pageloader