pageloader 4.0.0
pageloader: ^4.0.0 copied to clipboard

Supports the creation of page objects that can be shared between in-browser tests and WebDriver tests.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add pageloader

With Flutter:

 $ flutter pub add pageloader

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  pageloader: ^4.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:pageloader/pageloader.dart';
2
likes
90
pub points
51%
popularity

Supports the creation of page objects that can be shared between in-browser tests and WebDriver tests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

analyzer, build, build_config, built_value, collection, js, matcher, quiver, source_gen, webdriver

More

Packages that depend on pageloader