over_react 3.9.0

Dart js
Flutter web

A library for building statically-typed React UI components using Dart.

11
likes
80 / 110
pub points
89 %
popularity

We analyzed this package on Sep 18, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 2144 out of 2536 API elements (84.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:over_react/over_react.dart that imports:
  • package:over_react/src/util/context.dart that imports:
  • package:react/react.dart that imports:
  • package:react/src/react_client/private_utils.dart that imports:
  • package:react/src/js_interop_util.dart that imports:
  • package:react/react_client/js_backed_map.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 87 issues. Showing the first 2:

INFO: The value of the field 'defaultProps' isn't used.

lib/src/component/_deprecated/abstract_transition_props.dart:39:39

   ╷
39 │   static final TransitionPropsMapView defaultProps = TransitionPropsMapView({})
   │                                       ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/component/_deprecated/abstract_transition_props.dart

INFO: The value of the field 'defaultProps' isn't used.

lib/src/component/_deprecated/resize_sensor.dart:85:46

   ╷
85 │   static final ResizeSensorPropsMixinMapView defaultProps = ResizeSensorPropsMixinMapView({})
   │                                              ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/component/_deprecated/resize_sensor.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.35.0 <0.40.00.39.170.40.2
build^1.0.01.4.01.4.0
built_redux^7.4.27.5.117.5.11
built_value>=5.4.4 <8.0.07.1.07.1.0
collection^1.14.111.14.131.14.13
dart_style^1.2.51.3.61.3.7
js^0.6.1+10.6.20.6.2
logging>=0.11.3+2 <1.0.00.11.40.11.4
memoize^2.0.02.0.02.0.0
meta^1.1.61.2.31.2.3
path^1.5.11.7.01.7.0
platform_detect^1.3.41.4.01.4.0
quiver>=0.25.0 <3.0.02.1.32.1.3
react^5.6.05.6.05.6.0
redux>=3.0.0 <5.0.04.0.0+34.0.0+3
redux_dev_tools>=0.4.0 <0.6.00.5.20.5.2
source_span^1.4.11.7.01.7.0
transformer_utils^0.2.00.2.50.2.5
w_common^1.13.01.20.31.20.3
w_flux^2.10.42.10.102.10.10
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.09.0.0
args-1.6.01.6.0
async-2.4.22.4.2
boolean_selector-2.0.02.0.0
built_collection-4.3.24.3.2
charcode-1.1.31.1.3
cli_repl-0.2.0+10.2.0+1
cli_util-0.2.00.2.0
colorize-2.0.02.0.0
convert-2.1.12.1.1
coverage-0.14.10.14.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
fixnum-0.10.110.10.11
html-0.14.0+30.14.0+3
http-0.12.20.12.2
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
matcher-0.12.90.12.9
mime-0.9.70.9.7
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
node_preamble-1.4.121.4.12
package_config-1.9.31.9.3
package_resolver-1.0.101.0.10
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
sass-1.26.111.26.11
shelf-0.7.90.7.9
shelf_packages_handler-2.0.02.0.0
shelf_static-0.2.80.2.8
shelf_web_socket-0.2.30.2.3
source_gen-0.9.60.9.6
source_map_stack_trace-2.0.02.0.0
source_maps-0.10.90.10.9
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
test_api-0.2.180.2.18
test_core-0.3.11+10.3.11+1
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
vm_service-4.2.05.0.0+1
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
webkit_inspection_protocol-0.7.30.7.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.35.0 <0.40.0` on analyzer does not support the latest published version `0.40.2`

pubspec.yaml:13:13

   ╷
13 │   analyzer: '>=0.35.0 <0.40.0'
   │             ^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs